Plan to work on Formicula, difficulty getting it up and running

  • This is probably directed to Guite, but if anyone else is working on it or knows what to do I am all ears. I want to get Formicula up and running on ZIkula 1.4.5, but right now it's being a little finicky. I can get it to install, and the admin interface works just fine. However, when I try to go to a form

    myzikulasite.com/formicula/

    I get the file list of the formicula module. If you do this url

    myzikulasite.com/formicula/0

    I get a 404 error

    Thanks,
    Tim
  • On a site where I have it installed it works using

    example.org/contact/

    whereby contact is the display name of the module as defined in the Extensions administration.
  • Thanks for the reply Guite,

    I get a 404 not found error. This was on an upgraded site. When I used it on a clean 1.4.5 site. It worked just fine. I may have some garbage in the other site that is causing issues. Thanks for the help.

    On to coding....
  • I have made some good progress on getting Formicula up and running. I squashed about 5 bugs in the code and have it working with Form 0. I want to do some more testing, but when I have that done, I will submit a push request (if that is what it's called) to the Zikula/Formicula code.
  • FYI, I just finished testing and edits to Formicula that make it Zikula 1.4.5 ready. I have submitted a pull request. Thanks to Guite for getting it so close. It was pretty easy to take it the rest of the way. I anticipate it should work with 1.4.6 too, but have not had a chance to test it.
  • Formula 4.0.1 released with recent improvements.
Moderated by: Support (Group)