Migrating to new server -- issues

  • Hi all,

    I am migrating to a self-hosted server and am importing one of my older, but still very active Zikula 1.3.6 sites (yeh, I am still planning on upgrading to the latest as long as my modules work) -- News and WebLinks). I have exported the database through phpMyadmin and am importing it back through phpMyadmin. However, it looks like almost all of the data gets imported till at the very last, the import give an error message below. It looks like it all has to do with the date function? Would anyone has a suggestion as to how I could import the database without the errors?

    ===START -THIS is the phpmyadmin error it returns -- ===

    Error
    SQL query:
    --
    -- Dumping events for database 'musiquea_zikulaemn135'
    --
    --
    -- Dumping routines for database 'musiquea_zikulaemn135'
    --
    /*!40103 SET [email protected]_TIME_ZONE */;
    MySQL said: Documentation

    #1231 - Variable 'time_zone' can't be set to the value of 'NULL'

    ===END===


    And, if I try to go to my new site, it then gives out these error messages:

    ===START-These are the Zikula 1.3.6 error messages I get when accessing the new site --===

    Warning: Invalid argument supplied for foreach() in /var/www/html/lib/EventHandlers/SystemListeners.php on line 710
    Uncaught exception No argument "log.enabled" is registered with Zikula_ServiceManager in /var/www/html/lib/Zikula/ServiceManager.php line, 322
    #0 /var/www/html/lib/Zikula/ServiceManager.php(351): Zikula_ServiceManager->getArgument('log.enabled')
    #1 /var/www/html/lib/EventHandlers/SystemListeners.php(323): Zikula_ServiceManager->offsetGet('log.enabled')
    #2 /var/www/html/lib/Zikula/EventManager.php(196): SystemListeners->defaultErrorReporting(Object(Zikula_Event))
    #3 /var/www/html/lib/Zikula/EventManager.php(135): Zikula_EventManager->invoke(Array, Object(Zikula_Event))
    #4 /var/www/html/lib/Zikula/Core.php(382): Zikula_EventManager->notify(Object(Zikula_Event))
    #5 /var/www/html/index.php(16): Zikula_Core->init()
    #6 {main}

    ===END===
  • Seeing as there does not seem to be any suggestions as to how to fix these issues, I'll try again to upgrade from v.1.3.6 to v.1.4.6.

    Is there an upgrade path that I should follow to move up to the latest version? Do I need to upgrade by specific versions 1.3.6->1.3.7->1.3.8 etc till I get to the right version?
  • Maybe this?

    http://stackoverflow.com/questions/30670270/variable-time-zone-cant-be-set-to-the-value-of-null
Moderated by: Support (Group)